Docs portal

Creating a new document

To create a new document, begin by clicking on the +NEW DOCUMENT button at the top-right of the Dashboard page.

creating_new_document_1.png

An empty toolbox panel will appear to the left and an empty canvas will appear to the right. A menu bar appears at the top, and the title bar appears just above the toolbar.

new_document_1.png

Menu bar

The menu bar contains several menus, each of which consists of items for interacting with Grafo documents.

creating_new_document_3.png

File menu

The File menu contains these items.

  • New opens a new document.

  • Duplicate creates a copy of the current document.

  • Rename opens a popup window in which you can change the document title.

  • Explanations for Document History and Name this Version can be found in the Document History section.

  • Learn about Notification Settings in Commenting.

  • Learn about Move To in Dashboard Details.

  • Export As is covered in the Export section.

  • Document Properties , which is covered in Document Properties.

creating_new_document_4.png

Document properties

Click File > Document Properties to display a popup window containing default values for a number of editable properties for this document.

creating_new_document_5.png
Document IRI

The document IRI defines the @base and the ‘:@prefix IRI used when exporting the document:

03-06-doc-iri.png

It should be unique to the document. The default is http://www.gra.fo/schema/untitled-ekg.

Use Document IRI as Base Namespace — Check this box to use the document as the base namespace for the IRI.

IRI Prefix

The IRI prefix defines a second prefix, besides :, that can be used in place of the full document IRI:

03-07-doc-iri-prefix.png

The default is ‘gf’.

Document Description

A brief description of the document. It is exported as an rdfs:comment annotation:

03-08-doc-desc.png
Additional Prefixes

This list includes all of the default prefixes for a document. In addition, you can add custom prefixes to the list, and delete any of the existing prefixes. These prefixes are all included when the document is exported.

Prefixes can also be used within Grafo as a shortcut to set the IRI of the element. Click here for more details.

03-09-doc-add-prefix.png

Edit menu

This menu contains one item, Delete. Click this item to delete the item in the document that has the focus. A selected element can also be deleted by pressing delete on your keyboard.

Note

Since there are no elements on a new diagram, this menu item is disabled.

03-10-edit-menu.png

View menu

Click the items in this menu to zoom in or zoom out on the diagram.

03-11-view-menu.png

 

Title bar

The title bar, near the top of the page contains a number of features:

  • The Grafo logo, which is a link back to the dashboard.

  • Title of the document, which is editable at any time.

  • The user avatar, and avatars of any shared users currently viewing or editing the document.

  • Share button.

  • RDF button.

  • Comment button.

  • Search button.

titlebar_1.png

Title

The title of the document is editable at any time. By default, the title is "Untitled Document". We recommend that you give a meaningful and distinctive name to your Grafo document.

03-13-title.png

User avatar

The first initial of your first name appears in the avatar region of the title bar. If you have shared a document with another user that is currently viewing or editing the document, the avatar for that user will also appear here. Click on your avatar to view a menu containing links for Dashboard , API Documentation, and Logout.

Note

The user avatar also appears on the dashboard, and that avatar menu can be used to view your account information or logout.

titlebar_2.png

Share button

Click this button to share the document.

titlebar_3.png

Comment button

Click this button to add a comment to the document.

titlebar_4.png

Search button

Click this button to search the document.

03-18-search-button.png

Left panel

The Left Panel contains both the Toolbox and Detailed Information about the selected element.

left_panel_1.png

Toolbox

Grafo provides four primary tools for modeling:

  • Concept Tool

  • Attribute Tool

  • Relationship Tool

  • Specialization Tool.

03-19-toolbox.png

 

Detailed information panel

Click on an element in the canvas to display detailed information in the left panel below the toolbox.

If you click on a concept, you'll see Detailed Concept Information in this panel. Similarly, if you click on an attribute, you'll see Detailed Attribute Information in this panel.

detailed_info_1.png

Canvas

The canvas is In the main panel. Here, you add elements and establish relationships among the elements to build a complete knowledge graph. Begin by adding a concept.

canvas_1.png